The Odroid XU4, a true desktop replacement?

In my pursuit of a low cost, tiny, low power consuming desktop replacement, I’ve taken delivery of a tiny Odroid XU4, recently. This promises to be more powerful than my Raspberry Pi2 but is still a tiny RISC (ARM) computer.

The bare board, odroid XU4
The bare board, odroid XU4

For me, it has three major advantages over the Pi. It has 2GB of Ram and three USB ports, two of which are USB3, which don’t share bandwidth with the ethernet port, as does the Pi. Thirdly, you can boot from an eMMC or microSD card. Oh, and its CPU has 8 cores.

Before I start, do take the advice from the Odroid forums seriously. When they say use Etcher for flashing your eMMC Card, use Etcher. DD appears to work but I hit a load of problems.

As it arrived, well thought-out packaging.
As it arrived, well thought-out packaging.

I bought my Odroid direct from Hardkernel in Korea. It arrived surprisingly quickly. (Total cost, with import duty and Fedex carriage and admin fees £139.86) It arrived very well packed with everything I needed except an EU/UK mains adapter, but I had one of those.

First point. This is sold as a development Board, very sensibly, as it is not nearly as easy to use as a Pi, mainly due to a less mature user community. If you have not been stretched enough getting a Pi to do all that you want then maybe you should take the plunge and try the Odroid.

My XU4 came with Ubuntu on a 32GB eMMC board. It booted quickly and immediately into Ubuntu Mate 16.04 kernel 4.9. I was impressed, until I hit a couple of showstoppers. First was a lack of Dropbox. I could find no way of getting this to run on this ARM computer. Secondly, video playback was poor which I later discovered was a problem with linux Kernel 4.9. Kodi just failed to work at all.

The case,
The case,

My troubles started when I tried to install Ubuntu with a 3.10 kernel on which, apparently, video issues are not apparent. Currently there is some sort of issue with kernel 4.9 and Odroid. If you are following this path, do not think that you can just do the same as with a Raspberry Pi. You cannot. I had deleted the boot sector from the eMMC card and so the XU4 had a lengthy stay in the resuscitation ward while I repented for the errors of my ways. I went as far as getting an RMA to return it before the helpful Odroid folks talked me through a cure.

I tried flashing my eMMC card using Etcher and DD through Linux and etcher through windows and also flashing three different SD cards with Ubuntu kernel 3.10. All to no avail. My XU4 would not boot. I could see all the files on my PC so the cards looked OK. I’ve included my comments on the Recovery tool usage, further down, in case they are of any use to anyone. Later, I discovered that Etcher works better through one USB port than another – strange. With one, I always got errors and the other, none.

I now have Ubuntu 16.04 kernel 3.10, Android 7 which is excellent and DietPi working, which is so full of promise but certainly not for the newbie. I have found DietPi just too limited for my current Linux knowledge and required usage. My current preferred OS is Ubuntu Mate 16.04 kernel 3.10, which after many flashes of the eMMC card (it seems to be very robust) is working flawlessly. I also have Android 7 on the SD Card which seems a little slow to boot but that might be more due to the speed of my card. In comparison, the eMMC Card is very fast.

A very nice touch is a handy switch that allows you to boot from either the eMMC Card or the SD Card, as you decide.

I am also using DietPi on the SD card, a minimal linux image that is powerful, very nicely put together, but not for wimps. It is not really designed for the desktop user, but I am using it as such and have met numerous problems, mainly of my making or lack of understanding but also becuase the current image (Aug 2017) has one or two major issues that require some work arounds.

Generally speaking, the Odroid XU4 is a fast board but the fan can be a bit irritating at times. You can buy a version with a larger heat sink and no fan. Yes, this is truly a development board. Hard work but fun. It might just prove to be my looked for tiny, low coast, low power requirements, desktop replacement, linked to a 2TB external hard drive, for data.

Command Line

If you are a Linux user, here are some helpful commands:

3.10 image

9bb4088ef641e85e691d7aef1bc1a753 ubuntu-16.04-mate-odroid-u2u3-20160920.img

To change img.xz to img use xz as shown

xz -d -k ubuntu-16.04-mate-odroid-u2u3-20160920.img.xz

to find out which devices are mounted

df -h

To write the img to the eMMC card, I used DD (don’t), sometimes called Disk Destroyer – be warned.

sudo dd bs=1M if=ubuntu-16.04-mate-odroid-u2u3-20160920.img of=/dev/mmcblk0p1 conv=fsync

Must use sync several times to avoid data corruption

or use Etcher (Only use Etcher!!!!)

https://etcher.io/

To find out the Kernel number

uname -r

To add a new user

useradd -m new-user adds a new user with a home directory
eg  useradd -s <SHELL> -m -d <HomeDir> -g <Group> UserName
(from The Geek Stuff)
passwd new-user adds a password for new-user
\new-user ALL=(ALL:ALL) ALL gives new-user root access by using visudo to edit the sudoers file

Useful URLs

Useful information seems somewhat scattered, at present, there being no single comprehensive source of information.

Official Wiki https://wiki.odroid.com/start

Odroid Magazine. A comprehensive overview of the XU4 https://magazine.odroid.com/odroid-xu4

How to use the recovery tool:

I couldn’t use xz -dk as that reported “File format not recognised” so used Engrampa GUI instead to unzip the archive.
Then used DD, in my case

Code: Select all
sudo dd
if=android-4.4.4-alpha-4.9-sd2emmc_installer-odroidxu3-20170517.img
of=/dev/sdd bs=1M conv=fsync
[sudo] password for mate:
500+0
records in
500+0 records out
524288000 bytes (524 MB, 500
MiB) copied, 149.311 s, 3.5 MB/s

Then sync 5 times.

My tale of woe.

What’s the acronym for take all the forum advice seriously! TATFAS doesn’t trip off the tongue like RTFM.
I tried three different micro SD cards with almost the same result. Steady red and steady blue LEDS, fan on constantly, but no picture. This was with only the power supply and HDMI lead attached. Later, as discussed above, I discovered the reason why.

With two sd cards (both 8GB Kingston), the XU4 turned off after 2minutes 9 seconds and 2 minutes 0 seconds.(ie steady red LED, no blue and no fan). I am assuming that the third, a 32GB Samsung card was not functioning correctly (It had worked previously with an RPI2).

As I was about to give up, I tried booting from the eMMC card (32GB), no HDMI output but then suddenly I had a flashing blue light, the fan stopped and Android appeared on the screen. I wont bore you with the path I took to getting Ubuntu Mate 16.04, kernel 3.10 back on the eMMC but it took several attempts, a steep learning curve and included an SD installation first. The XU4 is not for the feint of heart. It is not called a development Board for nothing. However, it has great potential and a very good team and community behind it. Some other SBCs (Single Board Computers) seem to suffer from a lack of a dedicated community of developers, which are very important for us mere users and dabblers.

I have my desktop back
I have my desktop back

I have my desktop back. The Odroid etc normally live behind the monitor, out of sight.